WordPress6.5新功能-声明式插件依赖

江河/ 04月03日/ WordPress/ 浏览 261

在此之前 WordPress 在处理插件依赖关系方面是比较弱的。一般的就是使用 file_existt、function_exists之类的检查一下插件是否存在,再使用 is_plugin_active 检查一下 插件是否已经激活。还有就是使用 TGMPA 第三方库。


在 WordPress 6.5 中,管理插件依赖就非常简单了,只需要在插件头部声明依赖的插件就可以了:


/**
 * Plugin Name: 你的插件
 * Requires Plugins: 以来的插件
 */


是不是非常简单,幸福来得就是这么突然。


发表评论

暂无评论,抢个沙发...

客服 工单