微信版本过低,不支持微信小程序新特性怎么办?

10月/21日/小程序/浏览 952

在开发微信小程序的时候,如果使用了比较新的控件或API,难免会发生用户的微信版本较低,不支持新特性的情况。


一般的,这种情况,在开发小程序时,都是采取向下兼容的方式,即先判断(wx.canIUse)用户环境是否支持新特性,支持就使用新特性,


假如使用新特性的功能特别重要,没这个功能,这个小程序就没法活了,这种情况怎么办?


微信也给出了解决方法,可以引导用户去更新微信客户端。


wx.updateWeChatApp 更新客户端版本。当判断用户小程序所在客户端版本过低时,可使用该接口跳转到更新微信页面。


只要调用 wx.updateWeChatApp 就可以打开微信更新页面了,示例如下:


wx.updateWeChatApp({
	success: () => {
		console.log('success');
	},
	fail: () => {
		console.log('fail');
	},
	complete: () => {
		console.log('complete');
	}
})


发表评论

暂无评论,抢个沙发...

客服 工单